Results 1 to 6 of 6

Thread: Some of my lps aren't doing so hot.

  1. #1
    mbodell
    Guest

    Some of my lps aren't doing so hot.

    Two of my acans aren't doing so well and my frogspawn lost a head. I lost 3 heads on an acan within 3 days. I am thinking the mag might be low. I am probably just going to do a good size water change, but I don't understand why the heads would just disappear so quick without shrinking first. Any ideas?

  2. #2
    Banned
    Join Date
    Nov 2009
    Location
    New Jersey
    Posts
    370

    Re: Some of my lps aren't doing so hot.

    How long have you had the acans? I don't know much about acans yet, but that same thing happened to me when I was holding for Rich in 2 days Felt bad for him...Looked great the day after I picked up and acclimated to my tank, two days later gone.

    How many other acans do you have?

    Taz

  3. #3
    Peppermint Shrimp
    Join Date
    Oct 2009
    Location
    Jonestown,PA
    Posts
    111

    Re:Some of my lps aren't doing so hot.

    Time for testing

  4. #4

    Re:Some of my lps aren't doing so hot.

    Are the frogspawn and acan in the same area of the tank? Are there any other corals near them as well, a leather maybe?

  5. #5
    mbodell
    Guest

    Re:Some of my lps aren't doing so hot.

    I got rid of all my leathers except the anthelia. Would an aenemone kill a frogspawn head. I am think that could be the issue. The acan has been fine for 3 months an I have 5 other ones that look good still.

  6. #6

    Re:Some of my lps aren't doing so hot.

    It could be the anemone but who really knows for sure, unless you see it actually stinging the corals. Are the acan, frogspawn and anemone in the same area of the tank?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •