Results 1 to 4 of 4

Thread: Jaebo PP-15 & PP-8

  1. #1

    Jaebo PP-15 & PP-8

    Garbage. 100% junk. I don't know what the deal is....

    I purchased my firs pair of PP-15s 06-2017 and they were in my tank by mid July of last year BRAND NEW. They died this spring, and I have noted on my tank chronicle One of my PP-15s died in July and the other lasted until 09-2018. I replaced the pp-15 that died first with a PP-8, in late June/ early July some time, and it is dead now. I don't know what their common point of failure is, but is sure as hell has nothing to do with lack of cleaning. To be frank, every 4-6 weeks I clean them, and I know of twice that I cleaned the PP-8 thinking that perhaps they were more fickle.

    What the hell is up with these? What is their common point of failure. I have dickered with the pp-15s on many occasions, and it seems like something in the pumps is bad, as the controllers worked just fine for the last working model I had. Their website makes it impossible to contact them, because they don't like my US phone number, and from the looks of it, it I would guess they offer no sort of warranty. Any suggestions other then taking them to the shooting range and blasting them?
    Last edited by SquatchXXL; 10-19-2018 at 02:08 PM.

  2. #2
    Everyone thought these were the greatest thing ever when the came out. What happened? I guess they got cheap. Anyone have any running for a longer period?


    Sent from my iPhone using Tapatalk

  3. #3
    I did quite a bit of testing today on all 3 units, and the failure is inside the sealed housing. It seems that it is not giving enough power to cause the magnet on the impeller to spin. The control units seem to work, and the impellers spin with no problem....I don't dare get my finger in one, as I like my fingers not sliced up. I may list my extra parts for sale here, but it seems odd to me. I would have expected the electronics inside the controller to #@!#@!#@!#@! the bed first. I thought that a DC housing was just wound copper wire, but apparently there is something else that they put in there that is failing. I am only a basic electronics guy. I may cut one of the housings apart to find out what the hell makes it work.

  4. #4
    Vice President nkicks1's Avatar
    Join Date
    Feb 2015
    Location
    Mechanicsburg
    Posts
    647
    pp6 is 2 years old and doing fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •